$re = '/(?i)incident:(\w.*),eid:(\w.*),domain:(\w.*),contact:(\w.*)/m';
$str = 'incident:reset my password,eid:emmanuel.z.m.deluyas,domain:accenture@com,contact:09668674472';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);