re = /(?i)incident:(\w.*),eid:(\w.*),domain:(\w.*),contact:(\w.*)/m
str = 'incident:reset my password,eid:emmanuel.z.m.deluyas,domain:accenture@com,contact:09668674472'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end