use strict;
my $str = 'Please find the presentations:
href="/Portals/12/Documents/GE-Project/Amalty-WS/Joanna_POT Pb paint health econ env_RUS.pdf">Presentation 1';
my $regex = qr~(?:\G(?!^)|/Amalty-WS/)[^"\s]*\K\s(?=[^"]*")~mp;
my $subst = '_';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";