#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^a+(?:a(?=a*(\1?b)))+\1$"
Local $sString = "aab" & @CRLF & _
"aaabb" & @CRLF & _
"aaaaaaaaaaaaaaaabbb" & @CRLF & _
"aaaabbb" & @CRLF & _
"aaaaab" & @CRLF & _
"aab" & @CRLF & _
"aaabb" & @CRLF & _
"aaaab" & @CRLF & _
"aaaabb" & @CRLF & _
"aaaabbb" & @CRLF & _
"aaaaabbbb" & @CRLF & _
"aaaaab" & @CRLF & _
"" & @CRLF & _
"b" & @CRLF & _
"ab" & @CRLF & _
"abb" & @CRLF & _
"aabb" & @CRLF & _
"aaaabbbb" & @CRLF & _
"bbb" & @CRLF & _
"aaaaaa" & @CRLF & _
"ab" & @CRLF & _
"abbb" & @CRLF & _
"" & @CRLF & _
"aaaaaabbbbbb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")