import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^a+(?:a(?=a*(\\1?b)))+\\1$";
final String string = "aab\n"
+ "aaabb\n"
+ "aaaaaaaaaaaaaaaabbb\n"
+ "aaaabbb\n"
+ "aaaaab\n"
+ "aab\n"
+ "aaabb\n"
+ "aaaab\n"
+ "aaaabb\n"
+ "aaaabbb\n"
+ "aaaaabbbb\n"
+ "aaaaab\n\n"
+ "b\n"
+ "ab\n"
+ "abb\n"
+ "aabb\n"
+ "aaaabbbb\n"
+ "bbb\n"
+ "aaaaaa\n"
+ "ab\n"
+ "abbb\n\n"
+ "aaaaaabbbbbb";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}