$re = '/^a+(?:a(?=a*(\1?b)))+\1$/m';
$str = 'aab
aaabb
aaaaaaaaaaaaaaaabbb
aaaabbb
aaaaab
aab
aaabb
aaaab
aaaabb
aaaabbb
aaaaabbbb
aaaaab
b
ab
abb
aabb
aaaabbbb
bbb
aaaaaa
ab
abbb
aaaaaabbbbbb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);