re = /^a+(?:a(?=a*(\1?b)))+\1$/m
str = 'aab
aaabb
aaaaaaaaaaaaaaaabbb
aaaabbb
aaaaab
aab
aaabb
aaaab
aaaabb
aaaabbb
aaaaabbbb
aaaaab
b
ab
abb
aabb
aaaabbbb
bbb
aaaaaa
ab
abbb
aaaaaabbbbbb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end