#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9](?!.*[_.-]{2})[\w.-]{4,13}[a-zA-Z0-9]$"
Local $sString = "A_3.hj_3J" & @CRLF & _
"12_4.67_9012345" & @CRLF & _
"a-dFegv_f" & @CRLF & _
"12_4.67_9-0-1-2-3-4" & @CRLF & _
"F__3d66.K" & @CRLF & _
"6-_sd.6h9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")