const regex = /^[a-zA-Z0-9](?!.*[_.-]{2})[\w.-]{4,13}[a-zA-Z0-9]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9](?!.*[_.-]{2})[\\w.-]{4,13}[a-zA-Z0-9]$', 'gm')
const str = `A_3.hj_3J
12_4.67_9012345
a-dFegv_f
12_4.67_9-0-1-2-3-4
F__3d66.K
6-_sd.6h9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}