import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9](?!.*[_.-]{2})[\\w.-]{4,13}[a-zA-Z0-9]$";
final String string = "A_3.hj_3J\n"
+ "12_4.67_9012345\n"
+ "a-dFegv_f\n"
+ "12_4.67_9-0-1-2-3-4\n"
+ "F__3d66.K\n"
+ "6-_sd.6h9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}