$re = '/^[a-zA-Z0-9](?!.*[_.-]{2})[\w.-]{4,13}[a-zA-Z0-9]$/m';
$str = 'A_3.hj_3J
12_4.67_9012345
a-dFegv_f
12_4.67_9-0-1-2-3-4
F__3d66.K
6-_sd.6h9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);