# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d+\.\d+\.)(\d+)/\g<1>0\g<2>/gm;t' <<< "1.01.1
1.01.2
1.01.3
1.02.1"