using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+\.\d+\.)(\d+)";
string substitution = @"\g<1>0\g<2>";
string input = @"1.01.1
1.01.2
1.01.3
1.02.1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}