// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+\.\d+\.)(\d+)").unwrap();
let string = "1.01.1
1.01.2
1.01.3
1.02.1";
let substitution = "\\g<1>0\\g<2>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}