#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^DOCUMENTS/(?=[^\n/]*Disclosure)[^/\n]*\.pdf$"
Local $sString = "DOCUMENTS/COMPANYID.Name of Disclosure.YYYYMMDD.pdf" & @CRLF & _
"DOCUMENTS/COMPANYID.Some Other Document.YYYYMMDD.pdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")