using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^DOCUMENTS/(?=[^\n/]*Disclosure)[^/\n]*\.pdf$";
string input = @"DOCUMENTS/COMPANYID.Name of Disclosure.YYYYMMDD.pdf
DOCUMENTS/COMPANYID.Some Other Document.YYYYMMDD.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}