re = /^DOCUMENTS\/(?=[^\n\/]*Disclosure)[^\/\n]*\.pdf$/m
str = 'DOCUMENTS/COMPANYID.Name of Disclosure.YYYYMMDD.pdf
DOCUMENTS/COMPANYID.Some Other Document.YYYYMMDD.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end