#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "metric(?!.*_(?:dk|none))"
Local $sString = "business_metric_one" & @CRLF & _
"business_metric_one_dk" & @CRLF & _
"business_metric_one_none" & @CRLF & _
"business_metric_two" & @CRLF & _
"business_metric_two_dk" & @CRLF & _
"business_metric_two_none"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")