using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"metric(?!.*_(?:dk|none))";
string input = @"business_metric_one
business_metric_one_dk
business_metric_one_none
business_metric_two
business_metric_two_dk
business_metric_two_none";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}