# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"metric(?!.*_(?:dk|none))"
test_str = ("business_metric_one\n"
"business_metric_one_dk\n"
"business_metric_one_none\n"
"business_metric_two\n"
"business_metric_two_dk\n"
"business_metric_two_none")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.