using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*_min\.)\w+\.(jpg|gif)";
string input = @"desc_125f.jpg -> matched,
desc#_56.jpg -> not matched (contains #),
bla_bla.gif -> matched,
bla_bla.png -> not matched (extension is png),
desc_125f_min.jpg -> not matched (contains _min between a filename and an extension),
desc_min256.gif";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}