const regex = /^(?!.*_min\.)\w+\.(jpg|gif)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*_min\\.)\\w+\\.(jpg|gif)', 'gm')
const str = `desc_125f.jpg -> matched,
desc#_56.jpg -> not matched (contains #),
bla_bla.gif -> matched,
bla_bla.png -> not matched (extension is png),
desc_125f_min.jpg -> not matched (contains _min between a filename and an extension),
desc_min256.gif`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}