re = /^(?!.*_min\.)\w+\.(jpg|gif)/m
str = 'desc_125f.jpg -> matched,
desc#_56.jpg -> not matched (contains #),
bla_bla.gif -> matched,
bla_bla.png -> not matched (extension is png),
desc_125f_min.jpg -> not matched (contains _min between a filename and an extension),
desc_min256.gif'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end