import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*_min\\.)\\w+\\.(jpg|gif)";
final String string = "desc_125f.jpg -> matched,\n"
+ "desc#_56.jpg -> not matched (contains #),\n"
+ "bla_bla.gif -> matched,\n"
+ "bla_bla.png -> not matched (extension is png),\n"
+ "desc_125f_min.jpg -> not matched (contains _min between a filename and an extension),\n"
+ "desc_min256.gif";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}