package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(?[0-9]{2,3}\)?(\s|-)[0-9]{4,5}-?[0-9]{3,4}`)
var str = `'00 00000000'
'000-000000000'
'000 00000-0000'
'00 0000-0000'
'(00) 0000-0000'
'(000) 000000000'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}