import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(?[0-9]{2,3}\\)?(\\s|-)[0-9]{4,5}-?[0-9]{3,4}";
final String string = "'00 00000000'\n"
+ "'000-000000000'\n"
+ "'000 00000-0000'\n"
+ "'00 0000-0000'\n"
+ "'(00) 0000-0000'\n"
+ "'(000) 000000000'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}