re = /\(?[0-9]{2,3}\)?(\s|-)[0-9]{4,5}-?[0-9]{3,4}/m
str = '\'00 00000000\'
\'000-000000000\'
\'000 00000-0000\'
\'00 0000-0000\'
\'(00) 0000-0000\'
\'(000) 000000000\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end