using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*(?<=sqs\.)(.*?)\..*/)(.*)";
string input = @"https://sqs.us-east-1.amazonaws.com/636455853878/eagle-dev-events-save";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}