const regex = new RegExp('(.*(?<=sqs\\.)(.*?)\\..*/)(.*)', 'gm')
const str = `https://sqs.us-east-1.amazonaws.com/636455853878/eagle-dev-events-save`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}