re = /(.*(?<=sqs\.)(.*?)\..*\/)(.*)/m
str = 'https://sqs.us-east-1.amazonaws.com/636455853878/eagle-dev-events-save'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end