$re = '/(.*(?<=sqs\.)(.*?)\..*/)(.*)/m';
$str = 'https://sqs.us-east-1.amazonaws.com/636455853878/eagle-dev-events-save';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);