#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\n(.*) \("
Local $sString = "AUSTRALIA" & @CRLF & _
"BELMONT PARK (WA" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"R3" & @CRLF & _
"1/5/4/2" & @CRLF & _
"2/3/1/5" & @CRLF & _
"EAGLE FARM (QLD"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")