package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\n(.*) \(`)
var str = `AUSTRALIA
BELMONT PARK (WA
R3
1/5/4/2
2/3/1/5
EAGLE FARM (QLD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}