using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\w.-]";
string substitution = @" ";
string input = @"[APPLE/O.ORANGE*PLUM-11]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}