import re
regex = re.compile(r"[^\w.-]")
test_str = "[APPLE/O.ORANGE*PLUM-11]"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)