package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\w.-]`)
var str = `[APPLE/O.ORANGE*PLUM-11]`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}