$re = '/[^\w.-]/';
$str = '[APPLE/O.ORANGE*PLUM-11]';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;