# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(com\\/\w*\\/\S*\\/)(.*\\/)/$1/;t' <<< "https://letterboxd.com/film/12-angry-men/crew/"