use strict;
my $str = 'https://letterboxd.com/film/12-angry-men/crew/';
my $regex = qr/(com\/\w*\/\S*\/)(.*\/)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";