package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(*NO_AUTO_POSSESS)(*NO_START_OPT)^<option[\s]value[\s]*=[\s]*\"([^\">]*)\"[\s]*[^>]*>`)
var str = `<option value .`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}