$re = '/(*NO_AUTO_POSSESS)(*NO_START_OPT)^<option[\s]value[\s]*=[\s]*\"([^\">]*)\"[\s]*[^>]*>/';
$str = '<option value .';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);