re = /(*NO_AUTO_POSSESS)(*NO_START_OPT)^<option[\s]value[\s]*=[\s]*\"([^\">]*)\"[\s]*[^>]*>/
str = '<option value .'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end