package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)proc_notes_(January|February|March|April|May|June|July|August|September|October|November|December)\d{4}.txt`)
var str = `proc_notes_April2020.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}