import re
regex = re.compile(r"proc_notes_(January|February|March|April|May|June|July|August|September|October|November|December)\d{4}.txt", flags=re.MULTILINE)
test_str = "proc_notes_April2020.txt"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")