#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Compile success [0-9]+ Errors [0-9]+ Warnings Analysis time : [0-9]+\.[0-9]+ \[ms\]"
Local $sString = "VHDL/Verilog/EDIF/SystemC Simulator build 10.3.3558.6081 " & @CRLF & _
"" & @CRLF & _
"(c) 1997-2016 Aldec, Inc. All rights reserved." & @CRLF & _
"" & @CRLF & _
"License Number 0" & @CRLF & _
"" & @CRLF & _
" Welcome to VSIMSA!" & @CRLF & _
" This message was printed from `startup.do' macro file." & @CRLF & _
"" & @CRLF & _
"# creating library" & @CRLF & _
"alib work" & @CRLF & _
"ALIB: Library `work' attached." & @CRLF & _
"" & @CRLF & _
"Compile success 0 Errors 0 Warnings Analysis time : 31.0 [ms]" & @CRLF & _
"Compile Package "BT601_cfg"" & @CRLF & _
"Compile success 0 Errors 0 Warnings Analysis time : 15.0 [ms]" & @CRLF & _
"# starting simulation with tb_top as the top level module" & @CRLF & _
"# asim fpc_tb" & @CRLF & _
"# running the simulation" & @CRLF & _
"# run 1000us" & @CRLF & _
"echo hi" & @CRLF & _
"hi" & @CRLF & _
"quit"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")