import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Compile success [0-9]+ Errors [0-9]+ Warnings Analysis time : [0-9]+\\.[0-9]+ \\[ms\\]";
final String string = "VHDL/Verilog/EDIF/SystemC Simulator build 10.3.3558.6081 \n\n"
+ "(c) 1997-2016 Aldec, Inc. All rights reserved.\n\n"
+ "License Number 0\n\n"
+ " Welcome to VSIMSA!\n"
+ " This message was printed from `startup.do' macro file.\n\n"
+ "# creating library\n"
+ "alib work\n"
+ "ALIB: Library `work' attached.\n\n"
+ "Compile success 0 Errors 0 Warnings Analysis time : 31.0 [ms]\n"
+ "Compile Package \"BT601_cfg\"\n"
+ "Compile success 0 Errors 0 Warnings Analysis time : 15.0 [ms]\n"
+ "# starting simulation with tb_top as the top level module\n"
+ "# asim fpc_tb\n"
+ "# running the simulation\n"
+ "# run 1000us\n"
+ "echo hi\n"
+ "hi\n"
+ "quit";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}