#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9-]{0,8}([-][0-9-]{0,8})?$"
Local $sString = "20220623-19563352" & @CRLF & _
"20220623-18261367" & @CRLF & _
"20220606-15484894" & @CRLF & _
"20220606-15484" & @CRLF & _
"20220606" & @CRLF & _
"20220606-15" & @CRLF & _
"202206" & @CRLF & _
"33333333-33333333333" & @CRLF & _
"5453345345345353434646" & @CRLF & _
"3463334334535" & @CRLF & _
"202206a" & @CRLF & _
"2022067-+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")