// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0-9-]{0,8}([-][0-9-]{0,8})?$").unwrap();
let string = "20220623-19563352
20220623-18261367
20220606-15484894
20220606-15484
20220606
20220606-15
202206
33333333-33333333333
5453345345345353434646
3463334334535
202206a
2022067-+";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}