package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\| #033\[0m)(.*)(?:\.xcade\.net)(?:.*)(GET |POST )(\/.*)(?: HTTP)(?:.*)`)
var str = ` #033[0;36;1mnginx.1 | #033[0mlinkedinmiddleware-integrations.xcade.net 172.27.0.13 - fac4d3l1nked1nus3r [24/Sep/2019:14:25:04 +0000] TLSv1.2/ECDHE-RSA-AES256-GCM-SHA384 "GET /application/asiainspection HTTP/1.1" 200 103 "-" "-"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}