import Foundation
let pattern = ##"(?:\| #033\[0m)(.*)(?:\.xcade\.net)(?:.*)(GET |POST )(\/.*)(?: HTTP)(?:.*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##" #033[0;36;1mnginx.1 | #033[0mlinkedinmiddleware-integrations.xcade.net 172.27.0.13 - fac4d3l1nked1nus3r [24/Sep/2019:14:25:04 +0000] TLSv1.2/ECDHE-RSA-AES256-GCM-SHA384 "GET /application/asiainspection HTTP/1.1" 200 103 "-" "-""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)